Forum General Problem with compiled swf

Any issues or discussions relating to Flash development are welcome here.

Problem with compiled swf

Postby Sign002 » January 19th, 2013, 1:33 pm

Hello,

i have started work with PlayerIO few days ago. So i am a noob)
Someone help me please. After watching tutorials and examples, i have started building multiplayer in my game. This is my steps:
1. When flash is started, first i connect with server playerIO, after successful connect - create interface.
2. When player click on search a game:
if we dont have free rooms, we will create new room and w8 for other player, else we connect to room and start a game.
3. Game start - is a problem. Becouse when game started i create on stage new object "game" where create some new objects. They creating without problem in flash (fla), but in compiled version (swf, html) new objects in object "Game" does not created... Why?!


PS: sorry for my english...
Sign002
 
Posts: 2
Joined: January 15th, 2013, 7:52 pm

Re: Problem with compiled swf

Postby Benjaminsen » January 20th, 2013, 7:23 am

Make the simplest example that fails and post it here for us to review :)
Benjaminsen
.IO
 
Posts: 1444
Joined: January 12th, 2010, 11:54 am
Location: Denmark

Re: Problem with compiled swf

Postby Sign002 » January 20th, 2013, 11:47 am

Benjaminsen wrote:Make the simplest example that fails and post it here for us to review :)


Here it is:
screen_in_fla.png
Screen in fla (when test flash in Flash CS6)
screen_in_fla.png (281.18 KiB) Viewed 8496 times


Dynamic objects in selected zone by red oval/line , they are creating well when i test game in Flash CS6 (ctrl + enter).
As u can see on second screen - they are not created in compiled version that running in browser (i use Google Chrome).

Question - why in the compiled version does not generate dynamic objects?

*BG that you can see on screens - dynamic object that generated after connect to the room.

screen_in_brauser.png
Screen in brauser
screen_in_brauser.png (243.83 KiB) Viewed 8496 times
Sign002
 
Posts: 2
Joined: January 15th, 2013, 7:52 pm

Re: Problem with compiled swf

Postby ASH1138 » January 20th, 2013, 2:25 pm

Its not a problem with playerIO, more like a problem with flash or your code.
ASH1138
 
Posts: 285
Joined: November 17th, 2012, 2:29 pm


Return to General



cron